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FIX Eye is a tool designed to facilitate fast data search in FIX log files.

FIX Eye presents search results in an easy to work with form. It has 

intuitive graphical user interface and uses many familiar from MS Excel 

operational features.

FIX Eye can process multiple log-files distributed on the network.

Product overview
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• Search for FIX log-files on a local 

computer and a whole network

• Show FIX messages in a table

• Select FIX fields to be shown in a table

• Show FIX field names, values and 

descriptions

• Filter FIX messages by particular text 

in fields

• Recognize FIX version (4.0 – 4.4) from 

a log file

• Support Regular expression

• Read raw FIX messages from any text 

files (not cleaned FIX-logs only)

• Filter FIX messages by sessions

• Provide context search

• Create custom views

• Create custom filters

• Validate FIX messages

• Compare FIX messages

• Support FIX dialects

• Provide Order back trace 

• Support Multi-tab view

• Export selected cells to CSV

FIX Eye features

© 2009. EPAM Systems | B2BITS



FIX Eye.  Getting  Started: The Guide

FIX Eye main window

Data window

Panels with lists 
of files, 
dictionaries
and FIX sessions

Data window 
caption: chosen 
filter, view and 

search text

Filter and view drop-
down lists, search 
box and button

Data window 
message and error 
tabs

New data
window button

Search box

Message counter

Message validation
options

Status bar

Order and Session
back trace
buttons

Cancel current 
search

Remove all autofilters
Reset sorting

Error counter

Visible rows 
counter
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FIX Eye main window

The panels can 
either be docked 

on the main 
window or

pop-up in it 

Unchecked file 
records

List of log-files 
containing FIX 

messages

List of found
FIX-sessions

Column header 
with FIX tag

Column 
auto filter

List of dictionaries 
to define FIX 

Dialect
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• Click on the FIX Eye desktop icon to start the program or go to the Start menu 

and select “All Programs -> B2BITS -> FIX Eye”

• Choose data files: open the File menu and select “Open Log Files”, choose files 

with raw FIX messages and click “Open”

• Write a search query in a search box and click “Search”

• Double click on a raw message in the table to see FIX message details

At the very beginning FIX Eye displays the dialog form for opening log 

files. It can be done either  automatically – by hitting the “Search” 

button, or manually – after clicking “Browse”.

© 2009. EPAM Systems | B2BITS

Quick start



FIX Eye.  Getting  Started: The Guide

Go to “File -> Open Log Files…” or “File -> Open Log Folder…”

or use the    button on your toolbar

Opening file
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You can send log files to FIX Eye from any folder on your computer. 

Right-click a folder, select “Send To -> FIX Eye” and choose:

• “Files and Folders” if you want to send only files from folder

• “Files and Folders with Subfolders” if you want to send files with all subfolders. 

The sent files will be opened in a new instance of FIX Eye.

Sending to FIX Eye
New!
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FIX Eye allows creating multiple data windows (tabs). It is possible to 

specify different search text, filter and view for each data window. 

• Click on the “New message view” button to add a new tab or press “Ctrl” + “T”

• New data window with a clear search box will appear next to the current one. 

Multiple tabs

“New message view” button
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Type your search query (one or more words that best describe 

messages you want to find) in any search box in the main window and 

hit the “Search” button or click the     icon.

Data search

Search box

Cancel button

You can stop the search process by clicking the “Cancel” button 
on the status bar.
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Search results (namely messages) are sorted by relevance to the 

specified search terms. 

Search terms are indicated on the data window label and placed into 

the search box as well.

Data search
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You can search for a specific context in a raw message. 

• Double click on a message to open the “Message Details” window and enter your 

search query in the search text box. 

• Press “Enter” to go to the next search result or “Shift” + “Enter” to return to the 

previous one.

Data search

Search text box

Search results

New!
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Double-click on any FIX message in the table to view message details 

in a separate window or right-click the message and select “Show 

message details” from the context menu.

Message details
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You can compare two messages tag by tag in a separate window. 

• Hold “Ctrl” and select 2 messages from the table, right-click on them and choose 

“Compare messages” from the context menu. 

Please note, that if you select more than two messages, FIX Eye will 

compare only the first and the last one.

Comparing messages

New!
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• Click the appropriate table column header to sort messages. The first and the 

second clicks apply ascending and descending sorting to messages respectively 

by related FIX field values. 

• You can reset current sorting by pressing <Esc>.

Message sorting
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Click on the column header button    and select a required value from 

the drop-down list to apply auto filter.

Message auto filter

You can reset filtering for a particular column by selecting (All) item 
from the list
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• Select “Custom” from the column header drop-down list to create a custom filter. 

Set up a condition <operator> and a criterion <value(s)> to compare the current 

FIX field with some value(-s). 

• The filter criteria can either be selected from the drop-down list or entered by 

user.

Message auto filter

Operation list 
of custom filter

Criterion value
list and input box
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All opened log files are listed in the Files pop-up window. You can dock 

it in the left part of a main window by clicking on the Files title bar.

• Uncheck a file check-box to omit messages from that file in consecutive 

searches.

• Check this check-box to include the file content to the next search.

Files list

Unchecked file messagesList of log-files Context menu

© 2009. EPAM Systems | B2BITS



FIX Eye.  Getting  Started: The Guide

The list of sessions found in opened log files appears in the Sessions 

panel. 

Sessions list

Messages of all 
sessions

Messages of
unchecked 

sessions 
disappeared
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FIX Eye covers standard FIX-features by default, but you can work with 

non-standard FIX-dialects after loading special files (XML-format) that 

contain the necessary descriptions. 

• Go to “File - Load Dictionary” to load a new dictionary for a particular FIX dialect 

or right-click on the Dictionaries window and select “Add File(s)” from the context 

menu.

• Right-click on a file in the list and select “Remove File” from the context menu to 

remove a dictionary.

Dictionaries list
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FIX Eye is provided with a flexible and functional design that will help 

you create a personal interface tailored to your own needs and tastes.

You can dock, undock, resize and rearrange windows and tabs and 

achieve maximum comfort while working with FIX Eye.

Customizing interface
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The Files, Dictionaries and Sessions windows can be set to the 

following views:

• Pop-up panels (by default they are in the left part of a main window)

• Docked separate windows 

• A single docked window with 3 tabs

• Undocked separate windows

• A single undocked window with 3 tabs

The same pattern can be applied to the Message Details and 

Messages Compare windows.

Customizing interface
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Files | Dictionaries | Sessions

Pop-up panels (by default on the left)

Customizing interface
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Files | Dictionaries | Sessions

A single docked window with 3 tabs

Use      button to fix the window

Customizing interface

Tabs
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Files | Dictionaries | Sessions

Docked separate windows 

Use      button to fix the window and a mouse to drag it to a pop-up 

icon.

Customizing interface
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Files | Dictionaries | Sessions

A single undocked window with 3 tabs

Use      button to fix the window and double-click the title bar to undock 

it.

Customizing interface
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Files | Dictionaries | Sessions

Undocked separate windows

Undock the window, click on a tab label and drag it to separate 

windows.

Customizing interface
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Search results, i.e. messages that are listed in the table, can be 

displayed in:

• One window with multiple tabs (the default view)

• Multiple docked windows 

Use your mouse to drag and rearrange windows in FIX Eye.

Customizing interface
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Search results

One window with multiple tabs (the default view)

Customizing interface
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Search results

Multiple docked windows 

Customizing interface
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The Filter drop-down menu includes:

• The list of preset filters that can be applied immediately after selecting one of 

them

• Filter options for creating, modifying and deleting filter options

Data filter

Preset filters

Filter options

You can reset a filter by choosing the [Default 

Filter] option.
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Select the <New> item from the previous menu and set up an 

appropriate condition to create a new filter.

Data filter

Message pre-sets:
• all messages
• non-session
• session

New filter name

List of FIX-fields

List of conditions:
• match
• does not match
• present
• not present

Custom criterion. 
A regular expression 
can be used here.
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You can modify or delete a preset filter. First, apply any filter and then 

select <Edit> or <Delete> from the Filter drop-down list. 

You can save a back copy of the current filter by clicking on     button in 

your Filter window tool bar.

Data filter

Filter copy nameCopy button

New!
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You can use a regular expression in the filter. Enter it into the <value> 

field. This expression can be combined with other expressions if 

necessary.

Data filter

Regular expression

Additional expression

Add condition 

Remove condition

© 2009. EPAM Systems | B2BITS



FIX Eye.  Getting  Started: The Guide

You can address a field tag, which is a part of a repeating group while 

creating a custom filter. 

• Enter a repeating group tag, put a dot [.] and then a field tag, e.g. 453.452. 

Thus messages with a repeating group tag 453 that includes tag 452 

will be filtered.

Data filter New!
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You can customize message view (a set of displayed columns) in the 

table. Click on the view list to do that. 

The drop-down menu includes:

• The list of preset views that can be applied immediately after selecting one of 

them

• Options for creating, modifying and deleting views 

Custom view

Preset views

View options

You can reset a view by selecting the [Default 

View] option.
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The “Compact” preset view allows showing messages in compact form, 

i.e. numbers for tags and values without description.

Custom view

List of selected 
FIX-field tags 
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The “Detailed” preset view allows showing maximum information about 

messages. Tag names are displayed and field values are described.

Custom view

List of selected 
FIX-fields names
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The “Raw Data” preset view allows displaying messages in their raw 

view, i.e. as a row of symbols. 

Custom view
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The “Colored” preset view allows displaying messages in different 

colors, i.e. a particular color is assigned to  every message type, to 

facilitate visual perception of table data. 

Custom view

New!
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Select the <New> item from the previous menu and set up an 

appropriate condition to create a new view.

Custom view
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New view name

Field displaying 
rules:

• fields listed in 
“selected view 
fields”

• all fields except for 
listed in “selected 
view fields”

List of 
available 
FIX-fields

List of 
selected 

FIX-fields
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You can modify or delete a preset view. First, apply any view and then 

select <Edit> or <Delete> from the View drop-down list. 

You can save a back copy of the current view by clicking on the     

button in your View window tool bar.

Custom view

View copy nameCopy button

New!
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You can create your own color theme in any view. 

• Click the “Conditional Formatting” button and add the required formatting rules to 

the view. 

Custom view

New!
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You can edit formatting rules by clicking the corresponding button in the 

left bottom corner of the window. 

You can save a back copy of the current rule by clicking on the    button 

in your Formatting Rule window tool bar.

Custom view

Copy button

Formatting Rule copy name

New!
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Specify the condition and click the “Format” button in the Formatting 

Rule window to change font style, size and color and background color 

of messages displayed in the table. The “Sample” box allows checking 

the result of changes being made.

Custom view

Sample box

New!
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Click the message validation button to validate messages in the table 
against FIX-rules. 

Messages have 3 levels of validation:

• Well formed – message length and checksum match the corresponding field 

values

• Well formed and required fields – the same as above and all mandatory fields 

are present in a message

• Well formed and required fields and correct values – the same as above, plus 

message fields have correct values (e.g. numeric field has a numeric value, date 

field has some sensible date etc)

Message validation

© 2009. EPAM Systems | B2BITS



FIX Eye.  Getting  Started: The Guide

• Invalid messages are marked in the table with – I icon.

• Related error descriptions are placed into an error-tab of this data window. 

Double-click on the     icon to see the detailed description of an error.

Message validation

Invalid 
messages and 
descriptions of 
errors in them
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This feature shows a trade process as a chart of its states defined by 

related FIX-messages.

• Right-click on a message and select “Order Backtrace” from the context menu to 

see the chart.

• Click on the “Order Backtrace” button on the menu bar to open a form with all 

previous back traces that have not been closed yet.

Order backtrace
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• Click on a message or a state shape to see the related object details as a table. 

This table can either be docked on this window or detached as a separate panel.

Order backtrace

Sender 
CompID

Target 
CompID

CIOrdID

Sent messages

State / message 
details

State
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This feature shows a session process as a chart consisting of its states 

defined by related Logon and Logout messages and Test Requests.

• Right-click on a message and select “Session Backtrace” from the context menu 

to see the chart.

• Click on the “Session Backtrace” button on the menu bar to open a form with all 

previous back traces that have not been closed yet.

Session backtrace New!
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• Click on a message or a state shape to see the related object details as a table. 

This table can either be docked on this window or detached as a separate panel.

Session backtrace

Sender 
CompID

Target 
CompIDTrading SessionID

Sent messages

State / message 
details

State
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You can customize text displayed in shapes. Go to “Tools -> Options” to 

do that.

It is possible to create a dedicated string for each message and state 

type. It is also possible to put a field value into the string. Use %<tag>% 

string to address a specific tag or select a tag from the drop-down list at 

the bottom of  the form.

Order / Session backtrace

List of FIX-
message types

Insert selected field 
into message / state 
pattern 

List of FIX-field 
types
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You can export data from Order and Session Backtrace diagrams as an 

image or a plain text.

• Go to “File -> Export” and choose “Export Data” if you want to save messages in 

text format or “Export Image” if you want to save a diagram. 

Exporting backtrace data

“Save as type” drop-down menu in the next window will provide 

you with a choice of file format

New!
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You can export table data to a separate text file

• Select cells in the table

• Go to “File -> Save As”

• Choose the text file format (.csv or .fix)

Exporting table data
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Further information on the product is available 

at: www.b2bits.com, forum.b2bits.com

Contact manufacturer: sales@b2bits.com
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